Connection Refused [Windows][Port 8091]

Hi, I setup a couchbase server on my windows azure vm, that I am also using to serve my web app.

I was serving the app fine and making regular feature updates to it, when all of a sudden my app refused to connect to couchbase (I am using the default 8091 port).

I also discovered that I cannot login to the UI anymore (obviously).
The only thing that fixed this issue was deleting the couchbase windows service and reinstalling. This fixed this for a while, but after roughly 12 hours the issue came up again. I read somewhere that I needed an install path without spaces in it - I tried this too, to no avail. Last time I tried to reinstall after a mere 10 minutes the problem came up again, and I am currently unable to serve my application.

This sounds rather odd.

Is there a way to get the process listing from the service? Also, you might try sdk-doctor to check network connectivity.

  1. Check the network connectivity
  2. Verify whether port 8091 is using by any other resources
  3. Check the firewall status and verify whether 8091 port is opened.
  1. Network is working fine, I can serve files and create a remote session to the VM
  2. No, it isnt (verified with netstat -ano)
  3. It is open both for inbound and outbound

Moreover, it shows in the services.msc panel that the service is running, however when looking for processes listening on 8091, it seems that there are none!

Can you look for two things:

  1. when it’s in the “not working” state, see if there are any erl.exe processes (I’m pretty sure that’s the process name). There should be three, I believe.
  2. when it’s in the not working state, does the windows log have anything related to this service in the logging?

You may want to zip up the logs directory and file an issue. If you have an Enterprise subscription, you can open a case as well to have it reviewed with higher priority.

Sorry you’re running into this. It seems like something environmentally specific, as a number of people run on Windows and don’t have this issue.