Cannot connect to localhost on port 8091 to complete install

I went through the install process. When it opens my browser to have me complete the installation process, I cannot seem to connect to the admin via port 8091. Thoughts?

I’m not sure I will be able to help you but to shorten your time to solution by the experts I suggest you to provide the following:

  1. Operation system and version
  2. Couchbase version
  3. What kind of error or result do you get when you are trying to get localhost on port 8091


1 Like

You are correct. I should have included that info…

Windows 7
Couchbase 3.0
The error just says connection refused

Just curious if anyone else out there has run into this and has a solution. I ran a netstat and it does not even list port 8091.

I am simply confused as to why I am receiving ERR_CONN_REFUSED

The most common cause is a firewall. Does the Couchbase service show as running in the services control panel? If not, there may be some other problem.

When you say you ran a netstat, you mean that something like netstat -an doesn’t show LISTEN on port 8091? That’d be an indication that the process isn’t even running.

Yes, when run netstat, port 8091 does not even display. I did check my services and the couchbase server is running.

FYI, I tried to upload screenshots, but forum would not allow me to do so since I am new here.

We’ll need to look at logs to see why it’s not able to start. Couchbase Server ships with tool called cbcollect_info that is able to grab all the logs and diagnostics and pack it into .zip file. Please use that tool and pass resultant .zip file to us.

Best way to do that is via jira ticket (

There are several ways that you can do to diagnosis what’s going on here:

  1. From Windows Task Manager, go to process tab and click “Show processes from all users”. Check if there are any processes named as erl.exe, memcached.exe and moxi.exe.
  2. go to your root installation directory, say, c:\test, then go to c:\test\etc\couchbase, and open static_config. check if all path_configs point to valid directory path.
  3. run cbcollect_info.exe under c:\test\bin directory and upload the zip file for further analysis.

I put in a ticket after running cbcollect. Jira will not allow me to attach the zip file.

Check Task Manager…

Found two erl.exe
no memcached.exe or moxi.exe

Checked static_config…no tmp directory or couchbase-server.node file

Ran cbcollect…could not upload due to Jira hindering.

Let me know if there is anything else I can do or that you need.

Sorry for that jira problem. But note that you can still upload somewhere else. Like google drive. And post link.

Here is the cbcollect zip off of Google Drive…

May I ask where you installed the binary installation package from? In looking at the logs, I see the local installation at:


Did you build this from source, or install from the installation package at:

Choose “Run as Administrator” when running the executable installer.

Also, did you have it running previously by chance, and needed to reinstall?

I simply downloaded the package form and installed it. I did not ‘run as administrator’. I have admin rights on my machine, but I can try that.

I did not have it running previously.

So you explicitly installed it to c:/Jenkins/workspace/cs_301_win6408/couchbase/couchdb/src/couchdb ? Can you see what is at that location? Or is that just the directory structure for this class. Is it possible that this machine already has the source installed? Can you test in a Virtual Machine on this box? Can you test on another system?

Also, what is the specific download location and filename that you used?

Filename - couchbase-server_3.0.0-beta-windows_amd64.exe
Location - (Community Edition)