Curl: (7) Failed to connect to ********* port 8091: Connection refused

Unable to connect to couchbase server. Also getting many TIME_WAIT events

netstat -anp|grep -i 8091
tcp 0 0 TIME_WAIT -

Linux 8.2
couchbase versoin 7

its blocking our testing. can some one please help.

Hi @Praveen_Kumar9 Some basic things to check:

  1. Is there possibly a firewall blocking port 8091?
  2. Double check that the admin credentials you are providing with the curl command are correct.
  3. Do you have Couchbase Server configured to use HTTPS only? In that case it would use port 18091 instead of 8091.

Hello Kevin,

Thanks for your reply.

  1. We have installed Couchbase 6.6 version and it worked fine. We were able to access the configuration page without any issues. So, we can rule out firewall issue here.

  2. When I get the admin page on 7 version, it is not submitting and just refreshing when ever I click on submit button.

  3. We are continuously seeing below error in logs.

[ns_server:warn,2021-09-07t02:01:27.864-04:00,<0.268.0>:ns_memcached:connect:1202]Unable to connect: {error,{badmatch,[{inet,{error,econnrefused}}]}}.

  1. As being a new user, I am unable to upload debug log. Can you grant me permission for uploads?

“Connection refused” is a generic networking error that can have many different causes, including firewall but also others. Firewall or antilamware software might be the most common causes though. Have you tried grepping for “8091” in couchbase.log (and also logs//.log to see everything)?

Where are you attempting to upload logs? I am not familiar with this process – trying to find out.

@Praveen_Kumar9 There is an icon in the toolbar of the reply window to upload files – it looks like an up arrow rising out of a rectangle (7th icon in my toolbar).