Windows Service startup fails

Guessing this is a install issue, but can’t find more info.

windows 7

Windows service settings:
path to executable: …\Couchbase\Server\erts-5.10.4\bin\erlsrv.exe
start parameters: are empty, what should it be?

Also Couchbase\Server\var\lib\couchbase\logs is empty as I don’t think we are even attempting to start Couchbase.

Thanks for any help!

Generally speaking, all we do is start the erlang VM and pick up parameters from configuration files or create them if it’s a new install. Do you see any processes running when the service starts?

To diagnose, we’d need a cbcollect_info. The quickest way to get help would be to file an issue with it attached.

Thanks! I will keep looking and submit a issue if I don’t get farther. The service starts and stops quickly… nothing in event viewer, etc. With my luck it will be the virus software here at work.

Ran cbcollect_info, read through the logs. We have erlang machine stopped instantly. Looked that up and saw path issues between unicode and utf-8 from rabbitmq also erlang code. Created a short path e:\cbs still no luck same error.

Were you able to file an issue and attach it? We may be able to notice something more. One thing Erlang OTP often requires is a set of TCP ports to be open for interprocess communication. These are documented for Couchbase.

Another option if you need a quick turnaround and have an enterprise subscription is to talk with someone in support.

After an unrelated reboot I am up and running. Now I can start playing, thanks for the replies.