Impossible to resinstall Couchbase Server on Windows Server 2012

I have installed the Enterprise Edition on the test server on Windows Server 2012 6 month ago.

I would like to switch to the Communuty Edition 3.0.1 to have exactly the same version as the dev environement.
After resinstalling couchbase from the installer, the console interface looks like that:

Impossible to start the server.

I have uninstalled the community and finally reinstalled the enterprise edition… Same deal, no console, no windows service.

When I try to run the service_start.bat, service_register.bat, etc… impossible.
In some case erlsrv.exe says CouchbaseServer service already exist,
And when I try to remove it, it says that I don’t have enought privileges.

CouchbaseServer never appear in Windows Services.

erlsrv.exe seems to keept a track of the first installation as service and impossible to remove it.

This when I try to run the service_register.bat:

This is when I try to run service_reregister:

This is when I try to run service_start:

This is when I try to run service_stop:

And this is when I try to run service_unregister:

The issue looks like this one:

Thanks for any help.

Hi, as you’ll see from the ticket this is troublesome to reproduce and the root cause isn’t entirely clear. The problem can be worked around by clearing out the following registry entry:

1 Like

It’s more and less what ICT did on the server (clearing some elements in the registry) so we could re-install couchbase on the server and now it works like a charm.


which registry elements did you remove?

As far I remember, it was something related to Erlang, but I’m not 100% sure, it’s been a while from now.
We don’t use Couchbase on Windows any more.