Query Tab doesn't show all the scopes/collections

Hi all,

we are using Couchbase EE 7.2.0 and from the Query Editor, we can’t see all the created scopes and collections.
There are more than 45 collections and the UI shows only 30 collections.
We also queried the keyspaces and we had the same 30 as result.

Is there a limitation? Or is it a bug?

Hi @fabiosst - there shouldn’t be any built-in limitation there. I’ve seen a few rare cases where it takes some time for the UI to update when new collections are added but I’m surprised to hear that querying the keyspace also shows only 30. Are they all under one bucket/scope?

You might want to consider opening a support ticket so we can get your logs and troubleshoot it live with you.

Hi @perry,

the collections are created in the same bucket, but under different scopes.

Do you think it could be an issue?

@fabiosst, if you restart the cluster (or at least the Query nodes), do the additional collections appear?

Hi @dh,

at the moment I cannot restart the Query Nodes.
I missed an important information: I’m using a containerized Couchbase with the CAO 2.4.2.

From your suggestion, I tried to login onto each query nodes and each one of them shows a different number of collections. (3 nodes: 12,11,30)

@fabiosst I suspect https://issues.couchbase.com/browse/MB-57673. I believe the fix will be in a forthcoming 7.2.0 version (7.2.0-5335) but hasn’t been released yet; you can check your precise version with:

select ds_version();

A workaround should be simply restarting the cluster. Another possible option is to create via SQL++ a dummy collection and then drop it (via SQL++; the drop should force a refresh on the node) - the catch (assuming it works) is to repeat this on each Query node. (It also isn’t permanent; further changes will likely not be observed until another forced refresh.)

I confirm the creation and deletion of the dummy collection via SQL++ worked fine and triggered the refresh.

I’ll use this solution as a workaround until the fix release.

Many thanks!

HI @dh, I’ve read about the new 7.2.1 version that has been released, but the issue MB-57673 was not mentioned.

Is the fix present in this version or we still need to wait for a next release?

Hi @fabiosst, yes 7.2.1 does include the fix. The 7.2.1 changes were done under MB-57586.

(Both are back-ports of the original MB-56816; different numbers for the backports because both code streams were open at the same time - it was a late addition to 7.2.0.)