Join couchbase 7.1.0 server to existing 6.0.0 cluster


I have 2 CentOS VMs, I have setup couchbase and nginx using docker-compose file. First VM has cb:6.0.0 running and second one with 7.1.0. So, when I am trying to join 7.1.0 to the existing 6.0.0 cluster I was getting below error. But when I join the cluster 6.0.0 with 6.6.5 version then it is working

Unsupported protocol https

and I noticed an warning report in /opt/couchbase/var/lib/couchbase/logs/debug.log file

=========================WARNING REPORT=========================
Description: “Authenticity is not established by certificate path validation”
Reason: “Option {verify, verify_peer} and cacertfile/cacerts is missing”

So I was wondering are there any additional steps that I need to follow if I am using nginx container etc.
By the way I tried 7.1.0 and 7.1.1 and both has same problem

Hello @jeev

Thank you for using Couchbase Server. This issue is likely because you are missing the TLS certificates on the incoming node. This is a new security capability for clusters using uploaded certificates.

In the release notes for Couchbase Server 7.1.0.

  • Heightened security is now provided for adding nodes to clusters. Once a cluster is using uploaded certificates, a node that is to be added must itself be provisioned with conformant certificates before addition can be successfully performed. The new node is now always added over an encrypted connection. See Adding New Nodes.

and from the linked page

…once a cluster is using uploaded certificates, a node that is to be added or joined must itself be provisioned with conformant certificates, before addition or joining can be successfully performed: this means that the appropriate chain file (containing the node certificate) and private key must have been placed in the node’s inbox , and the appropriate REST API then called. From Couchbase Server Version 7.1, the new node is now always added or joined over an encrypted connection.

Thank you,
Ian McCloy, Couchbase Principal Product Manager

@jeev That’s a “big” jump it seems like you are trying to go directly from 6.0.0 to 7.1.0!

The document

Shows you need to go from 6.0 → 6.5 → 6.6 → 7.0 → 7.1x for both CE and EE of course on all steps look at the release notes.

Just to clarify, 6.5 or 6.6 are supported going directly to 7.1.0.
The documentation is being worked on to make this clearer.

Thanks for your suggestions. If I need to go from 6.0 to 6.5 then do I need to delete the docker volumes of couchbase server?

When I tried from 6.0 to 6.6.5 then I had to delete the docker volume because I saw in debug logs that it was still using old versions config.
And is that okay if we upgrade from 6.0 to 6.6.5 for EE?