Defining multiple buckets for same Connector


I have 2 buckets for Couchbase side of the connector. Im trying to replicate them via CBES connector to Elasticsearch. But there is not much information about this issue. What should i do to deal with this problem?
Can you give me a tip about this issue?


1 Like

I started playing with it today so I’m not a huge expert. Trying to understand how to move from ver. 3 to 4.
I think you need to have a different TOML file that contains the name of the bucket you replicate and the name of the indexes you store the types…
When running the cbes you can specify the path of the configuration TOML file.

1 Like

Yes, @israelolcha is correct.

Thanks for the answers, it worked ! :slight_smile:

I am not able to define two toml file in command… Only one toml file is running at a time which is last in --config command.

Hi, You should change the port the connector using. In connector config, there is port configuration for connector, (as far as I remember it was 31415). Change the second connector port to 31416 and start them again.

Thanks for the reply ,
I changed port number in both files one is 31415 and another 31416.
But still it is not working .

cbes --config ./cbes_connector/couchbase-elasticsearch-connector-4.0.0/config/toml1.toml & cbes --config ./cbes_connector/couchbase-elasticsearch-connector-4.0.0/config/toml2.toml
Only toml2 is working …

Question 1 - Have I run cbes connectors into two different docker images.
Question - I am running two cbes connector file in the same image . And expose both the ports 31415 and 31416 to image.