Couchbase UI Not Accessible

Hi Team,

We are running one couchbase container . The container IP able to ping but the UI is not accessible over 8091 port. When I tried to login from cbq-engine from container getting below error. Could you please advise.

Is there anyway we check couchbase service for containers running like we are checking systemctl status couchbase-server.service

root@23f3ce4997bf:/opt/couchbase/bin# /opt/couchbase/bin/cbq -u cbadmin -p cbadmin -engine=
ERROR 100 : N1QL: Connection failed Post EOF
N1QL: Unable to connect to cluster endpoint Error Get EOF


8091 should work - do you have port 8091 mapped to 8091?
port 8093 should also work - you might try that instead of 8091.

EOF indicates that something is listening, but it’s not http. Do you maybe have the kv port mapped to 8091?

cbq -u Administrator -p password -engine=http://localhost:11210
ERROR 100 : N1QL: Unable to connect to endpoint http://Administrator:password@localhost:11210: Get “http://localhost:11210/pools”: EOF

yes both 8091 and 8093 port is mapped to host port . We tested telnet is working on port 8091 but UI still not accessible . cbq utility also not working.

The EOF error you get indicates something is listening on that port - but it’s not the UI (or query) - both those are http which would give an http response, not EOF. And if nothing was listening the error would be

" ERROR 100 : N1QL: Unable to connect to endpoint http://Administrator:password@localhost:8099: Get “http://localhost:8099/pools”: dial tcp [::1]:8099: connect: connection refused"