Couchbase server 4.1 erl.exe high cpu usage

Both Couchbase 4.0 and 4.1 have an extremely high erl.exe CPU Usage. When hosting on Azure or AWS the cost is huge.

Is this an item that can be fixed? Any suggestions?


Hi @marco,

As far as I know, Azure doesn’t charge based on CPU usage, but rather on the size of the VM (number of cores, size of storage, etc). I’d be happy to be proven wrong (also I’m not much of an AWS user). Are you creating Couchbase nodes via the Azure/AWS marketplace? If so, what size VMs are you using?

Yea, Azure does charge based on CPU Usage. When I shut down the erl.exe’s from running and the CPU goes back to normal my bill drops. I can see it from my dashboard.

The CPU stays between 40 to almost 60%. This is even without queering server, just sitting idle. I tried AWS before Azure and similar results.

For this test I am using an Azure Standard D1 (1 core, 3.5 GB memory) VM. I installed the Couchbase Server 4.0.0 Community Edition available in Azure.



I want to believe you on the pricing, but I can’t find the CPU pricing information. This Stack Overflow answer seems to contradict you, and I don’t see anything about CPU load on the VM pricing page.

I would be happy to help you create a ticket (or create a ticket myself) if I could find some information to support your assertion that Couchbase is costing you more on cloud services. All I’m seeing is per-hour charges.

One thing that might be related is the size of the VM you chose (1 core, 3.5gb RAM). I think the recommendation is at least 4 cores and at least 4gb of RAM. That may (or may not) be why erl is running at so high a percentage.

I believe they have it under Compute Hours. But putting aside the Azure cost it, the biggest issue I would like to solve is the high CPU Usage. I will look into setting up a 4 core and 4GB of RAM test in the future to see if this is the problem. I searched on Google and it does not look like I am the only one with this issue but did not really find a solution.


I updated my VM to 4 cores but still have erl.exe high cpu usage just idling. I updated to the latest Couchbase 4.6 Developer Preview Community Edition. I might get rid of this Azure VM and create a new one.

I have the same problem. CPU usage is 100 with erl.exe! Version is 4.1.1., community. What is worse this bug or whatever prevents any requests to be executed. I was considering to use Couchbase as my prod database but not I have BIIIG doubts.

I have searched the web and we are not the only users having the same problem. It looks like it’s been going on for a while in different version including their latest. I really do love Couchbase but I would like to solve this issue having CPU at these levels all the time and no queries being run… weird.

So how can they live with this bug? It really prevents me (and probably others) from using Couchbase at all. I need to use some database on the mobile side and it’s the only database that has both versions for server and for mobile. But I’m ready to give up and move on towards weird, stupid, slow but working something else.

Yea, I hear you. It was suggested above to increase the VM Config but did not make any difference in my case. I am still wondering how the high CPU usage is constant even without doing anything on the VM Server… At some point I might setup a local computer as a Couchbase server with lot’s of power to see if it makes a difference.

@marco and @Kath,

Could you please collect the logs and send them so that we can look at this issue further?

Curious if you are also referring to Azure here @Kath

I will re-enable Couchbase on the VM and let it create log files.I am currently using v 4.6

ps: Is there any specific Log Files you would like for me to send you?


Couchbase Server logs at least, and any other logs about CPU usage that you think might be relevant.

@marco continuing the discussion from SO.

There was a known problem with Couchbase on Sierra. (It had to do with changes in Go support.) I’m assuming that’s what you ran into. The 4.6 developer preview fixes that. You can read more about it (and logs) in this thread: macOS Sierra support?

I believe this same problem affected Windows 10 Anniversary Edition, so if you were using that on Azure, 4.6 should also help there.

To download 4.6-DP:

To collect logs through the web console:

1 Like

I installed the latest build 4.6.0-3453 Enterprise Edition (build-3453). I used to have installed the v4.6 Community Edition. The erl.exe stays around 11%. I am wondering if the latest build is addressing the erl.exe issue or the Community Edition still has the problem. I am sure to test in the future with Community Edition.

@marco @kath we need log data to find the problem. We want to make sure it’s fixed in both EE and CE versions.

The ideal thing for us is to create a Jira ticket. Unfortunately registering is a little bit of a manual process, but not too bad. Go to for that.

Once you’ve created the ticket, you can capture and upload log data to attach to it. You can do this in two ways.

From the Couchbase Web Console:

  • Go to the “Log” tab.
  • Click “Collect Information” in the upper left.
  • Click the “Upload to Couchbase” toggle.
  • Fill in the other information (name and Jira ticket number).
  • Hit “Collect” (in the lower right-hand corner).

From the command line:

  • Find where “couchbase-cli” is installed. (Check here for help.)
  • Run couchbase-cli with the collect-logs-start command. (Details here.)
  • Wait for set of logs to be collected (should be quick).
  • Check the status with “collect-logs-status” command. (Details here.)
  • Stop logging with the “collect-logs-stop” command. (Details here.)

The collect-logs-start has options to upload and attach the data to a Jira ticket as well.


1 Like

I applied for the approval of the Jira ticket. As soon as I get access I will upload the log files.

I have this problem with RabbitMQ, so I think it’s an Erlang issue. Maybe isolated to when it’s running on Windows, not sure.