Couchbase Server 3/4 on Windows 8 not accepting remote connections

I’m posting my issue here because I can’t seem to resolve it, and couldn’t find any answers.

I tried to run Couchbase 3 (4 as well on one machine) on Windows 8.1. Everything is fine actually, as long as I try to access the server only from the machine its running on. But if I try on another machine, the connection times out (with telnet as well).

  • I disabled the firewall on both sides and the issue persisted (on ports 8091, 8092, 18091, 11211).
  • I ran an apache webserver on port 8091 instead of couchbase and that worked just fine.
  • My other client-server traffics works fine as well (tried on 5010, 8093)
  • With netlimiter I monitored the incoming connection to couchbase on one machine, and it came in fine, but after I allowed it, the connection still timed out.
  • I checked to see if it was listening properly on, and it was, but telnet still times out and netlimiter shows an incoming connection to erl.exe.

I chatted a bit with ingenthr (thanks for the help!) on the couchbase irc channel, but we couldn’t work it out.

So are there any others that tried to run Couchbase 3 on Windows 8.1? Did it work or not? I’ve searched for similar issues, but they’re all different sadly (not running locally, not even installing on win8, etc.), it’s just the remote connections that don’t seem to work.

I just tried this on Windows 10 and it works but it is worth checking: when you were setting up your first node, we do convert to your local IP.

  • What is the server name listed under the “Servers” tab for the node when you access it locally through the admin console?
  • Also When accessing locally, could you make sure to use the http://IP_ADDRESS:8091 instead of http://127.0… or http://localhost. Could you tell me if using the IP address locally works?
  • I tried it as, the actual IP address and a name that is listed in etc/hosts so I can switch IPs.
    also of note, i tried everything I mentioned in the OP as well before the server node was set up. So esentially trying to set up the node remotely (should that work normally though?).
  • Locally, using the IP address works. Using the same IP from another machine doesn’t.