I’m trying to use Couchbase.Lite libraries in AspNetCore 2 project, however, I’m getting a version conflict for Microsoft.Extensions.DependencyInjection. Would it be possible to use a higher version for this library?
Version conflict detected for Microsoft.Extensions.DependencyInjection. Reference the package directly from the project to resolve this issue.
CouchbaseTest -> Microsoft.AspNetCore.All 2.0.5 -> Microsoft.Extensions.DependencyInjection (>= 2.0.0)
CouchbaseTest -> Couchbase.Lite 2.0.0-db021 -> Microsoft.Extensions.DependencyInjection (>= 1.1.1 && < 2.0.0).
Another person brought this up. It is not possible to use a higher version because of many different issues so instead it will be dropped and a different dependency used in the next db.
Great! Any idea on when this build will be published?
Unfortunately I don’t know. It should have been out weeks ago but there some internal issues going on at the moment that are destroying our schedule. It will be out ASAP (hoping on the scale of just days)
FYI I blogged about my difficulty with this the first time I tried to upgrade the dependencies in case you are interested
I feel your pain. But in the long term moving away from .NET Standard 1 and MS Extensions was a right thing to do.