Couchbase 4.0 DP - Setup sometimes never finishes

I just downloaded Couchbase 4.0 DP to give it a try on an older MacBook Pro, running MacOS 10.10.3. I previously had CB 3.0.3 running on that machine, and it ran fine.

As instructed, I deleted the previous files using:

rm -rf ~/Library/Application\ Support/Couchbase
rm -rf ~/Library/Application\ Support/Membase

(Though there wasn’t a “Membase” directory on the machine.)

The application seems to launch correctly, with the icon appearing in the menu bar.

I then go to the web console and try to set up a new cluster. No matter what options I select, when I click the button the create the new cluster, the page switches to say “loading…” and never finishes, at least after 15-20 minutes. I tried different combinations of options, but every time the web console hangs. If I click “reload” the page goes back to the original splash screen with the “Setup” button. I tried restarting Couchbase, restarting the machine, and re-deleting the Application Support files, but nothing can get me past the setup stage.

This appears to be a intermittent failure. After trying this a bunch of different ways, here are some more details on how to reproduce this.

  • Start machine
  • Clean out the ~/Library/Application Support/Couchbase files
  • Launch Couchbase 4.0 DP
  • Go to the web console, click “Setup”
  • Select data, index, query, click “Next”
  • sometimes it makes it to the “sample buckets” page, if so click “Back” and “Next” again. Eventually it will hang with the “Loading” screen.
  • At this point it hangs consistently.