Help installing CB Server 4.5 on OS X 10.11

A few weeks ago I had CB Server working on my OS X system. I stopped working on CB for a while and tried to go back to my work today. I started the server, but it wasn’t responding at localhost:8091. I followed the installation instructions that said to delete the app, and ~/Library/Application Support/couchbase and membase. I downloaded again and started the app. Still no response on localhost:8091. This is awfully basic to have trouble with. Any suggestions?

Have you wallowed through the log files to see if anything is amiss there? The app may be starting, but may have issues that might send out error messages. I’ve made it a habit to always have running; it’s even provided warnings of a failing HDD I would not have seen in time.

If there was some funkiness going on, I’d expect there would be some sort of entry being made in /var/log/system.log.

Just to make sure, did you look at the Couchbase administrator log is deploying inside the web interface?

As for me, I’m still using 4.1.0-5005. Each time I start the server on my Mac, I always get a notification for an update. The problem is that it fails each time I try to install the update. I haven’t needed to update to 4.5 (I have on my Linux machine) yet and hasn’t been a priority.

I’m in the process of installing Couchbase 4.5 Enterprise on my El Capitan machine.

  1. I removed the application from `/Applications`,
  2. Deleted Couchbase files located at `~/Library/Application Support/Couchbase`. I see no memcache directory in my `~/Library`.
  3. Unzipped then ran the Couchbase 4.5 Enterprise application,
  4. I allowed about a half dozen incoming connections for 'moxi', 'projector', and others.
  5. Created my one bucket and copied back in my one document.

I had no troubles. Maybe you should check your firewall rules in System Preferences.

The only thing I forgot to do was move from ~/Downloads into /Applications.

There’s nothing interesting in var or any of the system logs. There was, however, a couchbase log. I copied some of it and put it in [my Dropbox] ( for you to look at. I’d appreciate it if you could take a look. It’s probably something obvious to someone who knows what it should look like. Thanks…

Warning: Autocorrect seems to transform ‘pathing’ to ‘bathing’.

I’m no expert, but I looked at the log you provided. I went through the package looking at various parts and noticed that the first error in your file seemed to be about bad pathing.

{bad_config_path, "/Developer/Databases @BIN_PREFIX@ Servers/couchbase-server-enterprise_4/Couchbase"}

That does not look like an appropriate path at all, but maybe it’s supposed to be a pair inside of quotes for all I know. But if Couchbase is trying to access the config file using the above, I can see why it wouldn’t be able to find what it needs (and in my case, the config file in question is empty).

In Terminal, run the following command at the CLI:

cat ~/Library/Application\ Support/Couchbase/etc/couchbase/static_config

Given that works properly anywhere it’s located in the file system, I’m not entirely sure that this static_config is even used. However, if maybe the incorrect path is what’s found in static_config, it could be your problem. It’s also strange that given there are a half-dozen paths set in that file, that only one is giving an error.

Edit: Seems that this file is updated each time Couchbase runs. I had kept Couchbase in my ~/Downloads and it showed up as such. I quick Couchbase and moved it into /Applications. Now static_config reflects this. If the path is still managed after the command you entered above, it must mean that Couchbase has the path(s) set somewhere inside the package or maybe in another file outside the application collection.

I’ll keep looking.