Constantly getting 12003 error on sample bucket

Hey there,
I am doing a school project on Couchbase DB and I can’t quite get the Query tab for my server to show me any results. The line I put in is

SELECT * from `beer-sample` WHERE state = 'California';

Sadly I get this as an output:

“code”: 12003,
“msg”: “Keyspace not found in CB datastore:”,
“query”: “SELECT * from beer-sample WHERE state = ‘California’;”

I tried to start small, but I got set back by this, and can’t really progress. Any help on this topic would be much appreciated!

Hi @Maupken,

Next to history there is list box. make sure you selected bucket.scope
If you select beer-sample, _default after FROM you need to give collection name

It kind of worked, now I got this error:

"code": 4000,
"msg": "No index available on keyspace `default`:`beer-sample` that matches your query. Use CREATE PRIMARY INDEX ON `default`:`beer-sample` to create a primary index, or check that your expected index is online.",
"query": "SELECT * from `beer-sample` WHERE state = 'California';"

Sadly after I try to create the primary index I get the following:

"code": 5000,
"msg": "GSI CreatePrimaryIndex() - cause: Fails to create index.  There is no available index service that can process this request at this time. Index Service can be in bootstrap, recovery, or non-reachable. Please retry the operation at a later time.",
"query": "CREATE PRIMARY INDEX ON `default`:`beer-sample`"

Hum. It should have worked.

Try Drop the bucket and Then
Settings===> Sample Buckets ===> Install the bucket again.
It should have created indexes.

Still the same error, on different sample buckets. Maybe it could be the error with server setup?

Try restart the cluster. cc @varun.velamuri


The indexer error means either index service is not configured in your cluster (or) the index service node is not available. What is your cluster configuration?

It looks something like this