Certificate Error While adding the Node to existing Cluster

Hi Team,

We had noticed that the node is part of cluster (Cluster is created with self-signed certificate) and due to some infra issue it removed so we rebalance the node. When the infra issue solved we are trying to add-back to cluster it is showing authentication failure.
To solve this issue we try to re-upload node certificate to cluster which lies in
/opt/couchbase/var/lib/couchbase/inbox/ folder but still getting error.

Could you please help me on the above issue.

Thanks,
Debasis

What error? ~-~-~-~-~

certificate_error
Please find the attached error. This node was previously part of cluster as told before.

https://www.google.com/search?q=adding+node+to+couchbase+cluster+"unknown+ca"

second link - https://support.couchbase.com/hc/en-us/articles/21263050059803-Certificate-related-issue-when-adding-a-node-to-the-Couchbase-cluster

Hi @mreiche ,

The article describes when we are adding a new node but in our case the node is already part of cluster and we had uploaded the node related certificates to cluster. Then when the node it is out of cluster why just reload certificates is not helping that particular node to add to the existing cluster.

Thanks,
Debasis

I don’t know. But usually following instructions works. If you follow the instructions and it still doesn’t work then open a ticket at issues.couchbase.com.

You can always save a round of me sending you the documentation and you responding - if in your initial post state “Here is the documentation I am following. I followed it exactly and still have this problem”. Otherwise I just assume that you didn’t follow the documentation.

You can also save a round of me asking “what error” if your initial post contains the error you encountered instead of just “I get an error” or “doesn’t work”.

The third link in that google search may also be useful. Also the openssl command is useful for debugging ssl issues.