Cbrestore dots issue


I am running into a suspicious issue. I have made a full backup of my cluster and I am now trying to restore from this backup to the same node but when entering the restore command it doesn’t do anything but keeps adding dots. I am using Couchbase 4.5 and tried all the examples on your 4.5 documentation page (as well as the 4.6 one):

I tried all sorts of combinations and one restore command did not produce rows of dots at first:
cbrestore -b bucket1 -B bucket1 ~/backup1/ http://HOST:8091 -u user -p pass
this was to restore a single node backup but this worked only once and now is producing dots just like all the other commands. Any suggestions?

UPDATE: so it seems it prints rows of dots commonly for every restore command. After about 30 rows it starts showing the progress bar with the estimated msgs. It seems like it works. The dots are still very odd and the restore progress bar goes from 1% to 133% and then restarts again for as long as there is more data I guess?
We found the issue what did not let us run the restore command in some cases (showed just the empty bucket’s msgs transferred and no progress bar) that was because the backup created a faulty file in the backup destination. If we deleted it, it worked “fine”.