Cannot complete install. localhost refused to connect

I am trying to install Couchbase 4.6.0 (Developer Preview) to a Windows 8.1 Pro machine (64-bit). After the install is complete I get a message stating there was a problem (timeout?) opening the console and to refresh the page manually.

When I try to go to http://localhost:8091/ I get an error that says:

This site can’t be reached
localhost refused to connect

Hi Mike -

Can you verify that the Couchbase Server service is running? See

Also, check the logs - if something got totally messed up, there should be something in error.log and you can post it here if it’s not self explanatory. See


HI Will,

Couchbase Server is running.

I checked error.log and it is basically 17000 + lines like this:

[ns_server:error,2017-01-06T08:37:54.478-05:00,ns_1@<0.179.0>:ns_server_nodes_sup:do_wait_link_to_couchdb_node:163]ns_couchdb_port(<0.178.0>) died with reason {abnormal,1}

A little Googling turned up this thread that had an underlying networking root cause: Start new Cluster

Can you take a look at that and see if it gives you any clues for something new to look at?

I didn’t see anything in there that made sense to me.

In attempt to rule out this being an issue with the developer preview, I uninstalled version 4.6.0 and installed version 4.5.1.

I had seen this thread earlier.

Looking through it I checked to see if erl.exe, memcached.exe adn moxi.exe were running. Task manager showed 2 instances of erl.exe running. Neither memcached.exe nor moxi.exe were listed on the processes or the details tab. CouchbaseServer shows as running on the Services tab.

I looked at c:\Program Files\Couchbase\Server\etc\couchase\static_config. All items pointed to a valid path except path_config_tmpdir. It points to C:/Program Files/Couchbase/Server/var/lib/couchbase/tmp, which does not exist.

I ran netstat -an. It does not list port 8091. (It does list port 8092.)

I ran cbcollect_info.exe. Here is a link to the output file.


Hi Mike,
It looks like another process (pid 4) grabbed port 8092 and that prevented the proper startup. (Whatever pid 4 is or was, it’s also running on port 80 I think).

Couchbase Server won’t start if its required ports are unavailable, so double check this list using netstat or similar:


do one simple thing, replace localhost with


I checked pid 4 and it is the system process. Obviously I can’t just kill it. :slight_smile: But that pointed me in the right direction. A little googling turned up this page:

That was exactly my problem. HP Support Solutions Framework Service was using port 8092. I disabled (eventually just uninstalled) it and was able to run Couchbase.

Thanks for your help.


Great, glad it worked out.