Updating To version 3.0.0 fails

Hello, today I got the notification for the release of version 3.0.0 and I am using version 3.0.0-1209-rel when I tried to install the update I got an error message after the download is complete: The update is improperly signed.

Can you please help me with that? thank you :slight_smile:

Can you give us more information on what OS and so forth? Also, if I’m not mistaken we do not support upgrades from betas/previews to GA versions, since there might be things changed in between. That said, there might be something else going on, but just to be safe maybe make a backup (cbbackup) and import it on a fresh installation.

Thank you for reply, sorry I forget to mention that I am using MacOS X 10.9.5

Additionally, I tried to start from beginning by downloading a fresh copy from the website, but it seems I don’t get the last version for that link either.
After downloading and installing this: http://packages.couchbase.com/releases/3.0.0/couchbase-server-enterprise_3.0.0-macos_x86_64.zip I still get the version Version 3.0.0-1209-rel as well as the update notice

I’m also getting a same message.

OSX 10.10

This issue has been reported in our Jira here -http://www.couchbase.com/issues/browse/MB-12319 and targeted for 3.0.2 release. Thanks

This is happening for 3.0.3. I downloaded latest from Couchbase site but it’s 3.0.3-1716-rel. Checking for updates reveals the release version, but I get the “improperly signed” message.

I’ve reopened MB-12319 and pointed to this thread. If you have any additional info, it’d be great to add it to the ticket there.

Unhuman, Can you tell us what’s your OS version? Are you on OS X Yosemite?

Yes, OSX Yosemite 10.10.2. Sorry for the delay.

Unhuman, Sorry for delay from my side now. OSX Yosemite 10.10.2 is not supported platform for 3.0.x version however we have added support for OSX Yosemite 10.10.2 in upcoming 4.0 release you can get early build this week 4.0-developer preview. Check this page http://www.couchbase.com/coming-in-couchbase-server-4-0.