Unable to install Community Server 2.2.0 on Windows 2003 server


my company is looking for a scalable NoSQL solution so we tried installing CouchBase Community server v2.2.0 on a Win32/W2k3 Server similar to our production environment.

The test server has a many different IP addresses and a couple of NIC interfaces built in as a loopback module, but other than that it’s a W2k3 Server vanilla installation.

CouchBase installs correctly in its folder, successfully starts the service (which is running) but the Console @ address http://localhost:8091 is totally unreachable.

We also tried uninstalling, disabling all the loopbacks and NIC interface and re-installed again: still no luck, service running but the browser is unable to connect to the given address.

Any idea about how to solve this strange bug?

The most common culprit for these kinds of symptoms tends to be some firewall configured.

If you rule that out, look in the logs. You may find an error log that may be able to show you what’s happening

We disabled the firewall on the test machine and the issue is still there. I also checked the “Logs & Logging” capter in Couchbase docs following your advice but the log folder provided for Windows (C:\Program Files\Couchbase\Server\log) doesn’t even exist on our system, meaning it wasn’t created by the installer. We tried manually creating the \log\ folder and stopping/restarting the windows service (which btw is starting and gets running just fine) and tried to relog to the http console, but nothing gets written there. We DO have a C:\Program Files\Couchbase\Server\var\lib\couchbase\logs\ with a bunch of “babysitter” files there, but I don’t know how to read them.

Do you ave any other advice? It would have sense to try the 3.0 beta (Community ed.) to overcome this kind of problem?

Many thanks,

Given that 3.0 is available, I would recommend trying that. There have been quite a few improvements.