Couchbase server community edition not starting

Hi, I am trying to install couchbase server 7.2.2 community edition. It’s installed fine but if I open localhost:8091, I am seeing the below error:

This site can’t be reached

localhost refused to connect.

Try:

ERR_CONNECTION_REFUSED

Mine is windows machine, I have checked services tab in Task Manager. Couchbase service is showing as “stopped”. I tried starting it manually, but it’s stopping by itself in few seconds. This same version was working fine in my machine until few weeks ago. I had to uninstall it for some reason, and when I am trying to install now again, it’s not working.

Can someone please help me with this?

Same here, I just downloaded community 7.2.4
Mac OS sonoma
and installed
it shows starting but no console window comes up
is it still localhost:8091?
regards
robr

@psruthishalini ; please have a look in your <install-dir>\var\lib\couchbase\logs directory: the error.log and/or info.log may indicate why the process is stopping.

(Edit: You may simply search all logs for “crasher”: findstr /m crasher *.log)

@robrucker1 I’ve tried the downloaded 7.2.4-community too, and it is listening on 8091 after installing. I have tried this on Linux and Windows.

If accessing with a browser, can you be sure to do a hard refresh (ctrl+reload / shift+reload) of the page ?

You can also check your <install-dir>/var/lib/couchbase/logs directory; you should have an entry like:

info.log:[user:info,2024-02-21T07:27:10.663Z,ns_1@cb.local:menelaus_sup<0.466.0>:menelaus_web_sup:start_link:38]Couchbase Server has started on web port 8091 on node 'ns_1@cb.local'. Version: "7.2.4-7070-community".

Further, you can check your netstat output and should see a listener on 8091.

If you’re missing the message/there is no listener on 8091, check the logs for any errors that may indicate an issue.