Python SDK on Windows under Anaconda 4.4 64bit

I’m using Windows 10 64bit and Anaconda 4.4 64 bit with Python 3.6.1. I managed to successfully install Python couchbase package at PyPi ( with pre-built C SDK 2.7.5 for amd64 ( Everything looks rosy until I tried to import couchbase.bucket when I got a DLL loading error:

“ImportError: DLL load failed: %1 is not a valid Win32 application.”

Anaconda3 64bit is the only Python on this computer. I have tried a few things without success. Anybody had the same issue? Help is appreciated. Thanks.

I haven’t used python client on windows, but for php you can get similar behaviour when runtime cannot load all dlls. for example, libcouchbase not in the load path.

You shouldn’t download a standalone version of the C SDK. The Python SDK comes prepackaged with its own version of the C SDK. It needs one for a particular visual studio version.

I’m not familiar with Anaconda though.

Thanks, Mark,

Too bad the prepacked Python is only for Python 3.4 the latest. It won’t install with Python 3.6 provided by Anaconda. I probably have to downgrade.

Thanks, Sergey,

The DLL should be in the path as if not, the compiler would have puked in the build process. Strange it complains for WIN32 while I’m using x64 library and Python installation.