Problems setting up Full Text Search on a single node

Could you please help me to enable FTS search on a single ubuntu server node?

Does it need to be run separately from the command line or is it now properly integrated into Couchbase server?

My node is currently running the Data, Index and Query service and I get the following message when I select Full Text from the Full Text section:

“The full text search interface is only available on Couchbase nodes running the full text service.
No full text search nodes were found on this cluster.”

How do I add the FTS service to the node. Adding, removing and rebalancing a single node system is a pain and not having the desired result.

Thank you very much.

Hi Alfie,

As with all services within Couchbase (Data, Index, Query, and FTS), it’s not possible to dynamically add new services to an existing server. You’ll need to either reinstall or swap/rebalance. The quickest way to do that, if you don’t want to lose your data, is to use cbbackup to backup your data, reinstall, configure the node with all the services running (including FTS), then restore your data.



you work with the FTS service exactly like with all others. You need to enable it on the first node when you initialize the cluster, and then when you add a new you can select it as well. The reason FTS is not enabled by default yet (you manually need to enable it on init) is that its still experimental. The next major release will have it enabled by default as well on initializaton.

@daves beat me to it :wink:

@daschl - just a few seconds in it!

@daves @daschl thank you so much for your replies and explanation.

I have a very simple one server setup. No real cluster at this stage. What I am struggling with is how to recreate the server with FTS enabled. Do you get the option if i reinstall to create the server with FTS enabled?

Correct - when you configure a node from scratch you’ll see it as an option, along with the other services. Just remember to check it, as it’s not enabled by default.

Wonderful. Thanks very much.