FTS service for Couchbase takes a long time to show up in cluster configuration


I’m currently using the Node.js SDK with Couchbase 6.0.1 but I’m running into an issue with Search queries.

Running any search queries a little while after I’ve booted up Couchbase, I receive an “Operation not supported” error. It looks like when the Node.js library first connects to Couchbase and does all the handshakes, the “fts” and “ftsSSL” services are not included in the cluster config response and so the library thinks the server does not support FTS. Meanwhile, I am able to execute search queries easily through the web UI and through the rest API.

I have to wait a pretty long time before the “fts” and “ftsSSL” services are included in the cluster config response and my queries start working again.


Does anyone have any ideas on how to fix this?

@rish In situations like these, a snippet from your code base on how you’re setting up the connection with the couchbase server using the SDK could prove pretty useful.

Pinging anyone in the #node-js-sdk to take a look.

Thanks Abhinav, I appreciate your response! :slight_smile:

I’m setting up the connection this way: https://github.com/DataDog/dd-trace-js/blob/64bfa46b087b3791f7db0f80975a15b2d57b867e/packages/datadog-plugin-couchbase/test/index.spec.js#L36-L41

I’ve ran it through Wireshark and it appears the Couchbase server is not telling the SDK that it has the Search query features available.

And in case you were wondering how I was setting up the server: https://github.com/rishabh/server-sandbox/blob/6.0.1/scripts/configure-node.sh (this is a fork of Couchbase’s server-sandbox docker image where I’ve enabled some more features)

Please let me know if there’s anything I can do to help, thanks!

@rish, Was it working without/before your custom overrides to the sandbox?

Hi Sreekanth,

I just checked and I can confirm that I get the same issue with the original server-sandbox docker image.