Index service not working

I’m unable to create index on my local machine - M1 MBP (macOS 12.5.1) / couchbase
enterprise edition - 7.1.0.

When running the query - CREATE PRIMARY INDEX ON default:test

I receive the following error

    "code": 5000,
    "msg": "GSI CreatePrimaryIndex() - cause: Index creation for index #primary, bucket test, scope _default, collection _default cannot start. Reason: Fails to create index.  There is no available index service that can process this request at this time. Index Service can be in bootstrap, recovery, or non-reachable. Please retry the operation at a later time..",
    "query": "CREATE PRIMARY INDEX ON `default`:`test`;"

I reinstalled couchbase server. Also tried to restart indexer service but it didn’t help.

Here’s the collected logs


Apologies for the long delay in responding to the question. We somehow missed the post.

I am not able to download the logs as they appear to be moved to trash. Is the issue still existing (or) was it resolved.

The error message is usually seen if there is no index service in the cluster (or) not all ports for index service are not available for index service to use.


@Otar , My colleague has downloaded the logs. We are currently investigating the reason for this behavior. I will come back to you on this in some time.

@Otar I did an initial analysis of the problem. It seems that the index service is unavailable, hence the index creation is erroring out. The reason for the unavailability of the indexing service is because the watcherServer is erroring out. I am looking further into the cause of the error.

Also is this a single node cluster or do you have more nodes in the cluster?

@Otar Couchbase server Enterprise Edition 7.1.0 is supported(only for developer testing) on M1 MBP (macOS 12.5.1) only in Rosetta mode. Please refer Supported Platforms

I upgraded to 7.1.1 and it solved the issue.