I Cant login to UI of Couchbase Cluster with TLS

Hi. I’m testing Couchbase-operator and couchbase-cluster with kubernetes and helm.

I successed to create Couchbase Cluster with default ID (Administrator) and Password (password).
I can login to cluster through couchbase-cli and couchbase UI without TLS.
But I can’t login to cluster through couchbase UI with TLS.

Do I have missing point to set ID, Password with TLS??

It should be exactly the same as non-TLS, just use port https://host:18091 rather than http://host:8091.

I used https://host:18091 with TLS.
Accessing Web UI is no problem. But when i login to it , UI says ID, Password is wrong.
But ID, Password is right.

Now i’m trying to access to 8091 port through the nginx ingress with tls.

And i found a interesting thing.
When count of couchbase server is 1, I can Login to it.
But When count of couchbase server is more than 2, I can’t login.

Is this problem related to setting of nginx??

Oh I know this one! Read this for an in depth explanation also add your voice to it as a customer and it may get fixed sooner https://issues.couchbase.com/browse/MB-31756

Just cross-posting here from Can't login couchbase UI for people interested, but the trick is to enable stickiness / affinity in the load-balancing, because the authentication cookie set by the UI is node-specific.

For nginx ingress controller, this is done by setting the nginx.ingress.kubernetes.io/affinity: cookie annotation.