Changing Couchbase Server application folder location error on Mac

I am new to Couchbase and am going through the initial setup. I accidentally ran the application from the downloads folder and when I moved it to the applications folder I kept getting errors about how the server could not find the app file (see below for details).

I tried uninstalling everything, reinstalling and opening from the applications folder but it never seemed to forget my original settings. I was also never prompted to go through the initial setup when reinstalling. I ran the commands to remove the application files but continued to get the same errors.

$ rm -rf ~/Library/Application\ Support/Couchbase
$ rm -rf ~/Library/Application\ Support/Membase

When I look at the UI console I get the following error…

Difficulties communicating with the cluster; displaying cached information! Buckets (3 buckets active)

The last error log is…

Service ‘memcached’ exited with status 1. Restarting. Messages: Failed to open library “/Users/MYUSERNAME/Downloads/couchbase-server-enterprise_4/Couchbase”: dlopen(/Users/MYUSERNAME/Downloads/couchbase-server-enterprise_4/Couchbase, 6): image not found

Has anybody had this problem? What is the cause? How to fix?


1 Like

I have the same issue- I just made a copy of Couchbase and pasted it back into Downloads/couchbase-server_4/

It works, but I’d like this to be solved for real for real…

Couchbase 4.5 and getting the same issue… wound up using the solution suggested by @tvongeld . Anyone know of a better option?