Getting _NetworkError_0x10 error while Couchbase database from Python code

I have a one node cluster.
I have tried to add new node to that cluster, but it did not allowed me to create new node to the cluster.
It was giving error for opening a port for the node machine that I was trying to add to the cluster.
After that I did not added the node to the cluster.

But right now I am not able to access the Couchbase database from Python query.
It is giving following error - _NetworkError_0x10 (generated, catch NetworkError): _Network…kError)()

I have restarted the couchbase -server and sync_gateway services.
Also I have Restarted the EC2 instance on which the couchbase is installed.
But still not able to get the data from Couchbase from Python code.

How to troubleshoot this problem.

most likely this is because your cluster renders addresses into configuration, which are not accessible from the client machine. Make sure Admin UI shows public IPs.

In Server Nodes Tab under ‘Server Node Name’ column it is showing private ips
So they needs to be public IPs.

Right now I have 2 nodes in the cluster.
How to get public IPs, without losing the data ?

If I try to add a node with public ip addess it is giving me error

" Prepare join failed. Could not listen on address ‘xx.xx.xx.xx’: eaddrnotavail"

I am getting above error if I specify the port or I do not specify port.

If I give private IP it does not give me this error.
If I give FQDN then also it is not giving me this error.

But I give private IP or FQDN then I am not able to access the Bucket from my client machine.
What can be solution for this.