Error on adding another server to a cluster

I have a CentOS 6.3 (I’ve tried with 6.5 also) server with Couchbase 2.2.0 CE installed and it’s running fine. I can see beer-sample data and I can add new buckets etc.

The problem appears when I try to add another server to the cluster.
I get no error connecting the second server to the cluster.
The rebalancing process ig going well, both servers show the same buckets and the correct amount of documents, BUT when I try to access the documents from any of the buckets it said that there are no documents in it and on the header bar I get the following error:
Error: ({ehostunreach,[{lhttpc_client,send_request,1}, {lhttpc_client,execute,9}, lhttpc_client,request,9}]})""

If I do a failover on the lates added server, I can again access the documents from the remained Couchbase server.

I suspect the CentOS firewall to block the communication between the two servers, but the ports are opened according to the Couchbase doc.

Any ideea?

I’ve just tried using the same servers but with the couchbase 2.0.1 version and this time is working perfectly.
So the problem looks to be on Couchbase 2.2.0 and it’s settings.

So still looking for a solution.

Are you adding the new node by IP or hostname? If via a hostname, check that all nodes in the cluster resolve that hostname to the same IP address.

Your thought on firewall is also a possibility - there are additional ports used by 2.2.0 compared to 2.0. See for a list of ports which need to be open. I’d suggest dropping the firewall to test if that solves the problem.