Enabling services while adding nodes to existing cluster

I am adding a node to existing couchbase cluster 4.0. am using curl command to add node but am getting below error
below is the command
curl -u Administrator:kodiak IP:8091/controller/addNode -d ‘hostname=[addnodeIp]&user=Administrator&password=password’ -d ‘services=[data | index | n1ql]’

[“Unknown services: [”[data | index | n1ql]"]"]

on removing services part, am able to add node but by default data services is only enabled. can any one with enabling services while adding node.

The services are kv, n1ql and index.


curl -X POST http://kodiak IP:8091/controller/addNode -d hostname=[addNodeIp] -d user=Administrator -d password=password -d services=kv,n1ql,index

There is an issue filed for this already: https://issues.couchbase.com/browse/MB-16877

Arun already knows this, but just so everyone else does too; I have submitted a change to the documentation to have the correct kv in there and not data. It should be on the site with the next round of changes.

Thanks kirk,arun. I am able to enable the services while adding node.