Curl command failed for port 8091

Hi Team,

We are trying to creating a ipv6 CB podman container and it was successful. After container creation when we are trying set auto failover and ipv6 family for container getting below error.

[root@localhost ~]# podman exec -it cbipv6 curl -X POST -u cbadmin:cbadmin http://localhost:8091/settings/autoFailover -d ‘enabled=false’
curl: (7) Failed to connect to 127.0.0.1 port 8091 after 0 ms: Couldn’t connect to server

We had disable the Firewalld service and checked the netstat command it is listens over 8091 port.

[root@localhost ~]# netstat -an | grep 8091
tcp6 0 0 2001:db8:1:0:d685::8091 :::* LISTEN
[root@localhost ~]#

Could you please advise why we are getting these kind of errors.

Thanks,
Debasis

Looks like you have only an IPv6 listener and are trying to connect via IPv4. Have you tried connecting via the noted listening IPv6 address ? (i.e. don’t use “localhost” as that is IPv4; use either “ip6-localhost:8091” (common IPv6 name, yours may differ), “[2001:db8:1:0:d685]:8091” or “[::1]:8091”)

HTH.

@dh Thanks for response. Actually as per internal doc after container creation we need to execute below two command then ipv6 will enable for container. Currently getting error on first command.

podman exec -it cbipv6  curl -X POST -u cbadmin:cbadmin http://localhost:8091/settings/autoFailover -d 'enabled=false'
podman exec -it cbipv6  /opt/couchbase/bin/couchbase-cli ip-family -c http://localhost:8091 -u cbadmin -p cbadmin --set --ipv6

Thanks,
Debasis

@Debasis_Mallick I based my response solely on your netstat output which clearly shows an IPv6 listener and no IPv4 equivalent. All I can say for sure is that unless there is a listener on IPv4 port 8091, e.g.

$ netstat -an|grep LISTEN|grep ":8091"
tcp        0      0 0.0.0.0:8091            0.0.0.0:*               LISTEN     
tcp6       0      0 :::8091                 :::*                    LISTEN     

you can’t use “localhost:8091” to connect.

If you don’t have IPv6 enabled on the OS in the POD, then there should be no need to follow any steps as only IPv6 listeners can have been created; Couchbase should be executing in IPv6-only mode already.

Have you tried to access any of the IPv6 endpoints to check on the state of the server?

Hi @dh we are able to build the container and cli mode able to connect but GUI mode while trying it is keep on spinning and there is no login screen.

Any suggestion why the login screen not showing.

NOTE:- The windows server where we are trying to access the GUI it is IPv6 enabled.

Thanks,
Debasis

Have you tried a hard-refresh of the page (control+F5 I believe on most browsers) ?

If you attempt a curl connection to the GUI login screen does it return the page’s HTML source with no HTTP errors?

1 Like