Created Couchbase Server, cant log in


I just installed my first Couchbase server, i made sure I KNOW the password when setting up the server, now I am at the login, i think the username is Administrator, the password, I know it. and… LOGIN FAILED… already impressed with couchbase :smile:

any idea what I did wrong, maybe the username? i remember the username it said when installed was Administrator, and the password is correct, why do i get a login failed? I tried to reset the password from the bin folder using cbresetpassword, that didnt work… any ideas??

perhaps try:


Case is definitely important.

If you’re still not sure, I just looked in /opt/couchbase/var/lib/couchbase/config/config.dat

I found my Administrator user and the password in clear text. If you’re sure about the password, search that file and find the string before that…

Also, later in that file appears to be some JSON, so you might be able to search on “userName”

Thank you unhuman for your reply,

I sadly uninstalled and installed again, funny thing is, same thing happened, until the 3rd time of uninstall and re-install, that I decided while i first setup and logged in, create a read only user, after that, the Administrator password I created from the setup worked… weird huh?

unhuman, are you a couchbase professional administrator, would love to pick your brain and learn more about couchbase if you dont mind?

Make sure you don’t have a corporate firewall or similar blocking your requests. One way to find out is to right click and “Inspect” your browser, and view the network tab when you click submit on the log-in. If you see a lovey corporate firewall message saying your traffic is blocked, you’ve found your smoking gun.