Coushbase 6.5.1 Community Edition non root install dependency issues

Hi All,

Facing an issue while installing couchbase 6.5.1 CE as non root user using the below command;

./cb-non-package-installer --install --install-location ./cb-install/cb-server --package ./couchbase-release-1.0-x86_64.rpm
which: no config(couchbase-release) in (/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin)
2020/09/24T09:13:15 ERROR: Cannot install Couchbase Server missing dependency: "config(couchbase-release)"

How i can resolve the above dependency to install couchbase 6.5.1 CE in AWS Linux2.
Thank you for the support.
Satheesh KK

Hi @satheeshkkmkd,

Thanks for using our product.

For package couchbase-release-1.0-x86_64.rpm, you only need simple install from rpm:

rpm -i couchbase-release-1.0-x86_64.rpm

This package is only use to install Couchbase server from repo. To install directly using Couchbase Server package, you could go to to the download page and download couchbase-server-community package and install it as the following steps. Replace couchbase-server-community-6.5.1-centos7.x86_64.rpm binary with couchbase-server-community-6.5.1-amzn2.x86_64.rpm one.

>[nonroot@s44015 ~]$ rpm2cpio couchbase-server-community-6.5.1-centos7.x86_64.rpm | cpio --extract --make-directories --no-absolute-filenames

1040292 blocks

[nonroot@s44015 ~]$ cd opt/couchbase/

> [nonroot@s44015 couchbase]$ ./bin/install/ \`pwd`

To start server:

[nonroot@s44015 couchbase]$ ./bin/couchbase-server \-- -noinput -detached

The maximum number of processes for the couchbase user is set too low (4096).
It must be at least 10000.
Normally this can be increased by adding the following lines to
couchbase              soft    nproc                  <value>
couchbase              hard    nproc                  <value>
Where <value> is greater than 10000. The procedure may be totally
different if you're running so called "non-root/non-sudo install" or
if you've built Couchbase Server from source.
[nonroot@s44015 couchbase]$

Check beam.smp processes, couchbase server starts as expected.

[nonroot@s44015 couchbase]$ ps aux | grep beam.smp
nonroot   53901  0.7  0.7 3291016 30864 ?       Sl   16:00   0:02 /home/nonroot/opt/couchbase/lib/erlang/erts- -A 16 -sbwt none -- -root /home/nonroot/opt/couchbase/lib/erlang -progname erl -- -home /home/nonroot -- -smp enable -kernel error_logger false inetrc "/home/nonroot/opt/couchbase/etc/couchbase/hosts.cfg" dist_config_file "/home/nonroot/opt/couchbase/var/lib/couchbase/config/dist_cfg" -sasl sasl_error_logger false -hidden -name babysitter_of_ns_1@cb.local -proto_dist cb -epmd_module cb_epmd -ssl_dist_optfile /home/nonroot/opt/couchbase/etc/couchbase/ssl_dist_opts -setcookie nocookie -- -noshell -noinput -noshell -noinput -run ns_babysitter_bootstrap -- -couch_ini /home/nonroot/opt/couchbase/etc/couchdb/default.ini /home/nonroot/opt/couchbase/etc/couchdb/default.d/capi.ini /home/nonroot/opt/couchbase/etc/couchdb/default.d/geocouch.ini /home/nonroot/opt/couchbase/etc/couchdb/local.ini -ns_babysitter cookiefile "/home/nonroot/opt/couchbase/var/lib/couchbase/couchbase-server.babysitter.cookie" -ns_babysitter nodefile "/home/nonroot/opt/couchbase/var/lib/couchbase/couchbase-server.babysitter.node" -ns_babysitter pidfile "/home/nonroot/opt/couchbase/var/lib/couchbase/" -ns_server config_path "/home/nonroot/opt/couchbase/etc/couchbase/static_config"
nonroot   53943  4.1  1.6 3338644 67300 ?       Ssl  16:00   0:11 /home/nonroot/opt/couchbase/lib/erlang/erts- -A 16 -sbt u -P 327680 -K true -swt low -sbwt none -MMmcs 30 -e102400 -- -root /home/nonroot/opt/couchbase/lib/erlang -progname erl -- -home /home/nonroot -- -smp enable -setcookie nocookie -kernel error_logger false -sasl sasl_error_logger false -user user_io -run child_erlang child_start ns_bootstrap -- -smp enable -kernel error_logger false inetrc "/home/nonroot/opt/couchbase/etc/couchbase/hosts.cfg" dist_config_file "/home/nonroot/opt/couchbase/var/lib/couchbase/config/dist_cfg" -proto_dist cb -epmd_module cb_epmd -ssl_dist_optfile /home/nonroot/opt/couchbase/etc/couchbase/ssl_dist_opts -couch_ini /home/nonroot/opt/couchbase/etc/couchdb/default.ini /home/nonroot/opt/couchbase/etc/couchdb/default.d/capi.ini /home/nonroot/opt/couchbase/etc/couchdb/default.d/geocouch.ini /home/nonroot/opt/couchbase/etc/couchdb/local.ini

If you have any question, drop me a line at thuan at couchbase dot com

1 Like