Couchbase server 5.5.3 - Where can we change the XDCR Max Replications

There is an article mention about Max Replications:

May I know where can we can change in couchbase server 5.5.3 ?

Thank you


Hi tinygipxy,

This setting has been deprecated since 4.x.
I saw your other post regarding beam.smp’s high memory consumption and would like to suggest restarting the nodes. (refer Beam.smp memory usage) .
If this doesn’t fix your issue, please provide logs and I will follow up.


Hi Pavithra,

That post only mention about upgrade version and my version already 5.5.3. Let me explain my issue in detail:

  1. The beam.smp process is steady increase memory usage and after about 4 hours, it will take up full memory of machine and then couchbase server is shutdown.

  2. This is my machine memory&CPU usage:

As you can see there are 4 time couchbase server shutdown at 3PM, 8PM, 1AM and 7AM

  1. This is the memory usage history of only beam.smp

  1. For all couchbase log, you can download from here:

Thank you


I’m runnig couchbase and experienced System OOM where the VM is not responsive on redhat 7.6. Here is a log snippets. The beam.smp process is consumming the memory to the point where the VM has to be restart.

I see a mentioned the XDCR Max Replication is deprecated in 3.x but from the couchbase-client there is parameter xdcr-replicate option for --settings.

May 22 20:10:52 my-node-02 kernel: Memory cgroup out of memory: Kill process 56153 (beam.smp) score 1373 or sacrifice child
May 22 20:10:52 my-node-02 kernel: Killed process 56106 (beam.smp) total-vm:2029508kB, anon-rss:419076kB, file-rss:3568kB, shmem-rss:0kB
May 22 20:10:52 my-node-02 kernel: [43762] 1000 43762 363346 31000 117 0 969 beam.smp