Uneven Ram Usage in cluster due to Bean.smp


we have a cluster composed by 3 nodes with the same hardware (4 x CPU, 20 GB Ram)

a week ago an instance went down because the disk usage was 100%, so we added more disk space and restarted the instance

since then the other 2 nodes of the cluster have a very high ram usage

and looking in the machine i found out that the beam.smp process is using all that ram

this doesn’t seem like a normal behavior…

what can I do to fix this?

I thought I could restart the instances on node1 and node2 …

has anyone had the same issue?

Thanks in advance

Adding details:

OS is CentOS and CB version is 4.5

Hi Andrea,

Did you find out what takes up most of the memory in the ones with high memory usage?
Our issues might be related


Hi k,

the process bean.smp is using the 85% of the ram on the tho nodes

yea, I think that our two issued are related too!

Have you tried to restart it?


Have you tried to restart it?

I think restarting it helps. Given that the server’s memory graph shows a sawtooth pattern and last time it dropped was when I restarted the container. I’ll do this at a more convenient time and possibly upgrade to 4.5.1.

There are 3 memory leak fixes in 4.5.1, that might help. If you are by any chance upgrading before then, let me know if it resolves the issue.

I can’t upgrade the version…

but I’m afraid by a scenario… let’s say I shutdown the istance one, what happens to the istance 2 that is starting from 92%?

I think I will restart all 3 nodes out of business hours

let me know if you have any news :slight_smile:


Hi guys,

I found a workaround for this issue, I just removed and added back again the nodes in the cluster with high ram usage

after like a minute the ram usage was back to normal

let me know if this works for you too


Hi @andrea.deidda
This solution worked for sometime, but the usage went high again.


Couchbase version : 5.0.1

Hi @pradyut.joshi
I am getting the same issue with beam.smp and other couchbase internal processes. Were you able to resolve this issue?

Apologies for the late reply, but yes, it was resolved.
We found that the VM on which couchbase server was installed had some problems. Weird, right ? We also didn’t think of it, because we tried everything:
-upgraded the couchbase server to latest version
-reinstalled it many a times
-kept only one bucket with 8GB RAM
nothing worked. Only option was to install it in a different machine. And voila! it worked, that too with minimal requirements.