Couchbase console shows troubles communicating to the indexer

I have setup a Couchbase 4.0.0 community (build-4051) cluster of 4 nodes. Recently I tried building primary index on a bucket in this cluster:

$ /opt/couchbase/bin/cbq
> CREATE PRIMARY INDEX `mybucket-primary-index` ON `mybucket` USING GSI;

However, one of the node had it’s port 9999 not closed, and I got the following warning in couchbase console:

Warning: We are having troubles communicating to the indexer process. The information might be stale.

Following is my indexer.log [link] ( I have since opened port 9999 on all nodes and tried restarting each couchbase node one-by-one, yet the warning persists.

How can I fix this? By the way, I also tried giving public access to /var/local too.

Checked the indexer.log file.
There was trouble connecting to projector, reason I couldn’t figure out
without other log files.

But eventually I see that projector connections are successful,

2016-02-21T22:45:37.298Z-06:00 [Info] KVSender::closeMutationStream INIT_STREAM Treating projector.topicMissing As Success

and the streams start on the server side.

2016-02-21T22:45:37.624Z-06:00 [Info] DATP[->dataport “:9105”] started …
2016-02-21T22:45:40.372Z-06:00 [Info] DATP[->dataport “:9105”] new connection “” +1
2016-02-21T22:45:40.914Z-06:00 [Info] DATP[->dataport “:9105”] new connection “” +2
2016-02-21T22:45:41.489Z-06:00 [Info] DATP[->dataport “:9105”] new connection “” +3
2016-02-21T22:45:42.151Z-06:00 [Info] DATP[->dataport “:9105”] new connection “” +4

after this I am not seeing any timeout in the log file.


Index eventually becomes active as well.

InstanceId: 14837406287430379651 Name: sampleweb-primary-index Bucket: sampleweb State: INDEX_STATE_ACTIVE Stream: MAINT_STREAM

Which is subsequently deleted:

2016-02-22T00:45:36.19Z-06:00 [Info] clustMgrAgent::OnIndexDelete Success for Drop IndexId 14837406287430379651