We are having troubles communicating to the indexer process


We tried to build secondary index on one of the cluster servers (4.1.1 in testing). The index was built to its 50% and the indexing progress stopped. Now we see this error message: “Warning: We are having troubles communicating to the indexer process. The information might be stale.”

Is there a way to revive the indexer? We tried restarting the couchbase-server process but it doesn’t help…

Have you tried dropping the index? Indexes can be dropped even when they’re being built.

@deepkaran.salooja Any suggestions?

@alex1, please check your indexer.log to see if there are any errors. Otherwise you can share it here.

In general, if you are still in testing phase, it is recommended to upgrade to 4.5.1 release. You also have the option of Memory Optimized Indexes in 4.5 which offer high indexing throughput and low latency for queries.


Thank you all!
We created replicas of indexes and this way managed to overcome the problem of one of indexers in the cluster becoming unresponsive.