Connection timed out error when Couchbase. Lite version updated to 2.8.6 in dot net


We have windows application developed in dot net. Previously we have Couchbase. Lite, Couchbase.Lite.Support.NetDesktop with version 2.8.4. We tried to update it to 2.8.6 and installed application, We got an exception “Pull CouchbaseLiteException (NetworkDomain / 3): connection timed out”. Is there any thing to add or am I missing any library/dll to update. Please find the log file attached. (1.6 KB)

Thank You
Anusha k


This is a question for the Mobile category. @borrrden can you help?

Did you update both Couchbase.Lite.Support.NetDesktop and Couchbase.Lite packages to 2.8.6?

Yes, I updated both to 2.8.6

The logs are showing you have failed including the correct nuget packages. So I think you have to make sure you are not include the older version of CBL nuget packages and clear the cache and include the correct version nuget packages and try build your solution again. Make sure remove the bin/obj folders before rebuild the solution. And make sure CBL nuget packages version have to match cross solution.

I was tried to clear and rebuild. But I found that there are two folders in our app i.e., X86, X64 in these folders we have two dll’s “LiteCore.dll, e_sqlite3.dll”. Which is created by other team mate he is not working now. So, when we update CBL is necessary to add those dll’s in X86, X64 folders. Even I tried to find those dll’s but after updating CBL I’m unable to find “LiteCore.dll, e_sqlite3.dll”.

Can you please suggest me where should I find those libraries if it is one of this issue.
Thank you

I am not familiar with e_sqlite3 lib. It’s not part of CBL libs. And I don’t think your should manually include the LiteCore.dll. Once you have the correct nuget packages cross solution, the LiteCore.dll should just be placed at the correct path and you shouldn’t do anything else.

Okay, Just now I was tried by clearing cache, bin/obj folders. Reinstalled new exe again getting same exception. "Pull CouchbaseLiteException (NetworkDomain / 3): connection timed out”. I don’t know what I’m missing. I was checked the version of CBL in bin folder it has latest only.

@AnushaKaidapuram Can you share me the whole logs? Verbose log will be the best.