Cbtransfer --single-node does not seem to work

I am running the following code:

/opt/couchbase/bin/cbtransfer -x data_only=1,batch_max_size=200 -t 2 -v --single-node --destination-operation=add -b mybucket -B mybucket -u administrator -p ‘mypassword’

But it does not do anything, giving me the following message:

mt cbtransfer…
mt source : couchbase://
mt sink : couchbase://couchbase.destination.io:8091
mt opts : {‘username’: ‘’, ‘source_vbucket_state’: ‘active’, ‘destination_vbucket_state’: ‘active’, ‘verbose’: 1, ‘dry_run’: False, ‘extra’: {‘max_retry’: 10.0, ‘rehash’: 0.0, ‘data_only’: 1.0, ‘uncompress’: 0.0, ‘nmv_retry’: 1.0, ‘conflict_resolve’: 1.0, ‘cbb_max_mb’: 100000.0, ‘mcd_compatible’: 1.0, ‘try_xwm’: 1.0, ‘backoff_cap’: 10.0, ‘batch_max_bytes’: 400000.0, ‘report_full’: 2000.0, ‘seqno’: 0.0, ‘batch_max_size’: 200.0, ‘report’: 5.0, ‘design_doc_only’: 0.0, ‘recv_min_bytes’: 4096.0}, ‘single_node’: True, ‘bucket_destination’: ‘mybucket’, ‘destination_operation’: ‘add’, ‘vbucket_list’: None, ‘threads’: 2, ‘key’: None, ‘password’: ‘’, ‘id’: None, ‘bucket_source’: ‘mybucket’}
2015-06-14 17:01:21,522: mt bucket: mybucket
bucket: mybucket, msgs transferred…
: total | last | per sec
transfer data only. bucket design docs will be skipped.

0 msgs transferred… however, mybucket has ~20000000 item counts.

If I do this without --single-node option, it seems work fine.
What would be the reason for this?

Hi Dynamicscope,
How many nodes is there in the cluster?

This could happen if there are no documents in the specific node, perhaps due to an uncompleted rebalance operation?

@martinesmann Thank you for the reply.

I have 3 nodes. (I performed the script after rebalancing completed.)

(Active / Replica)
Node1: 6.74M / 5.72M
Node2: 5.71M / 6.73M
Node3: 6.75M / 6.75M

I ran the script on every node, resulting the same.
FYI, I am using Couchbase Server 3.0.1 CE. And I don’t have any design docs in source cluster.

There’s no node named in your cluster so that’s why you get 0 msg with --single-node.
Do not use as the node source, use the real node name as you see it in the GUI or from “/opt/couchbase/bin/couchbase-cli server-list -c”.


Awesome~! Problem solved.
So I needed to use the real node name for --single-node option.
Thank you a lot~!