--single-node option of cbbackup doesn't work correctly with Couchbase-server v3.0.0 and v3.0.1


I’m trying to back up Couchbase cluster with cbbackup like this.

cbbackup http://HOST:PORT /backup/ -u USER -p PASSWORD --single-node -v

But it just backed up only design documents, not real data. When I specified a bucket with -b option, backup bucket by bucket worked correctly from the entire cluster but it also didn’t work with --single-node option and even -x data_only=1.

Am I missing something? Or cbbackup has a problem?

For your information, I had this when I executed the tool:

{‘username’: ‘’, ‘verbose’: 1, ‘dry_run’: False, ‘extra’: {‘max_retry’: 10.0, ‘rehash’: 0.0, ‘data_only’: 0.0, ‘uncompress’: 0.0, ‘nmv_retry’: 1.0, ‘conflict_resolve’: 1.0, ‘cbb_max_mb’: 100000.0, ‘mcd_compatible’: 1.0, ‘try_xwm’: 1.0, ‘backoff_cap’: 10.0, ‘batch_max_bytes’: 400000.0, ‘report_full’: 2000.0, ‘seqno’: 0.0, ‘batch_max_size’: 1000.0, ‘report’: 5.0, ‘design_doc_only’: 0.0, ‘recv_min_bytes’: 4096.0}, ‘single_node’: True, ‘vbucket_list’: None, ‘threads’: 4, ‘mode’: ‘full’, ‘key’: None, ‘password’: ‘’, ‘id’: None, ‘bucket_source’: None}

Everything looks right what you were doing.

could you try -n for dry run also?

Thanks for your reply. I tried -n for dry run, and it just said “done, but no data written due to dry-run” without any error messages.