Cbimport missing from Community Edition

I have noticed that cbimport is missing from the latest Community installation. Is this by design? Is it ok to copy cbimport from a temporary Enterprise installation? I have verified that this works.


Any updates? Is it ok to copy cbimport from (a temporary) Enterprise install to a Community install?

I think @anil would know the details. Anil?

Any updates? This is for this KB article, I will just instruct users to copy in cbimport unless I hear otherwise from you, thanks https://support.unity3d.com/hc/en-us/articles/115004052703

So @anil ? The problem is still there :slight_smile:
And same question for cbexport.

Well for export : Json export failed: Cluster at is not Couchbase Enterprise Edition


That’s a shame a tiny feature like that is only for Entreprise

1 Like

cbimport was missing in CB 5.0. CE.

Now 5.1 is released, and cbimport is included also in CE, but when attempting to use it it throws the error that @srm mentions:

Json import failed: Cluster at is not Couchbase Enterprise Edition

Any work around?

Hi ,
could you please help me ,
I am using cache manager from (http://cachemanager.michaco.net) how to do json configuration for Couchbase , We are trying to connect couchbase buckets using dotnet core and json but it failed to read bucket details.

// “$schema”: “http://cachemanager.michaco…”,
“couchbase”: {
“useSsl”: “false”,
“operationLifespan”: “12000”,
“servers”: [ “http://Localhost:8091"” ],
“buckets”: [
“name”: “test”,
“useSsl”: “false”,
“password”: “test123”,
“connectionPool”: {
“name”: “custom”,
“maxSize”: “10”,
“minSize”: “5”


“cacheManagers”: [
“maxRetries”: 1000,
“name”: “cachename”,
“retryTimeout”: 100,
“updateMode”: “None”,
“handles”: [
“key”: “couchbase”,
“knownType”: “Couchbase”,
“type”: “”

“serializer”: { “knownType”: “Json” }



Please help me as soon as possible, we are struggling since 10 days.


You’ll be better off posting in the right category and not just replying to an unrelated post @muralikrishna.dotnet.

I don’t know that your configuration looks correct there. I think servers would be hostnames/IP addresses, not URLs. You might double check that or post in the right category.

Cbimport is still missing in 5.0.1 CE in 14.04 edition.

@ingenthr Any updates on this topic?

I don’t have any updates on cbimport missing, I was just replying to the off topic post. @anil: can you assist with the cbimport question?

Hi @PureRockets, @srm, @jaj, @rhytha,

Firstly, many many apologies for long delay in my response.

CBImport and CBExport are new tools which are currently not shipped with Community Edition and only available in Enterprise Edition. However, we plan to make those tools available in Community Edition in future release and here is the tracking JIRA ticket MB-27487.

To import CSV data in Community Edition you can use cbtransfer which is shipped in the product.

Thank you!

Anil Kumar

@anil Is it ok to temporarily install Enterprise edition to get CBImport, and then install Community? See how Unity is recommending Couchbase to its customers here https://support.unity3d.com/hc/en-us/articles/115004052703


Any update on when cbimport will/might be released for CE? We are currently doing a trade study and are evaluating your product, but find that we cannot load JSON docs with curl commands… and have tested cbimport - it has impressive timings for loading data (we tested with enterprise), but really need to test with CE.

Appreciate your help!


I would like to know also when cbimport will be available for the Community edition… It is very hard to work without it…

My suggestion might be to temporarily install Enterprise Edition and obtain cbimport from there. Then uninstall it and properly install Community Edition.

I am on 5.0.1 and Mac OSX and had the following experience.


  • Installed CB Enterprise and imported my JSON files using cbimport
  • Un-installed Enterprise and installed Community Edition but kept the DB Data Directory.
  • The Server failed to start or at least the admin portal was not working. My guess is that the DB Data Files directory left over from Enterprise is not compatible with the Community Edition ???


  • Installed CB Enterprise and imported my JSON files using cbimport
  • Used cbtransfer to backup all my buckets
  • Un-installed Enterprise also deleted the DB Data Directory and installed Community Edition.
  • Used cbtransfer to import all my buckets in.

Basically you need to have a spare Enterprise server to use as the importer exporter and then transfer your data to the Community version as needed…

A pain but a work around…

No don’t use Enterprise at all like that. You may be in violation of the terms. Instead follow my directions, just copy cbimport

I tried that a long time ago… If I just copy certain binary files form the Enterprise version and use them with my Community version then it won’t work…

— output from running cbimport
Json import failed: Cluster at is not Couchbase Enterprise Edition

Ah got it. It worked for me but it’s been awhile, about 6 months ago