Cbimport doesn't work with the remote server

Hi guys. There is a problem with cbimport tool which works fine locally but doesn’t work with my dev and prod environments.

Input (all connection data is artificial):
/Applications/Couchbase\ Server.app/Contents/Resources/couchbase-core/bin/cbimport json -u #user# -p #password# -b #bucket# -d file://cosmos/short.json -g "#UUID#" --format list -c couchbase://

Response (there are multiple strings like this but I show them once):

2022-06-06T10:50:11.333+03:00 (Gocbcore) CCCPPOLL: Failed to retrieve CCCP config. ambiguous timeout
2022-06-06T10:50:11.333+03:00 (Gocbcore) CCCPPOLL: Failed to retrieve config from any node.
2022-06-06T10:50:53.326+03:00 (Gocbcore) Pipeline Client 0xc000536a10 failed to bootstrap: dial tcp i/o timeout

Could you please suggest what can be wrong with the access. I’m currently checking the version with the 11210 port access for my user but it’s only a speculation now. Any suggestions would be appreciated.

Which Couchbase Server version?
Can you try specifying the port to be used? Example: couchbase:// or use
And, check that port 11210 is open/accessible?
Also, try using the --log-file ./cbimport.log option to get a log capture.

In 7.1, when I use -c couchbase:// , I can see messages like:
2022-06-08T11:55:11.472-07:00 (REST) (Attempt 1) (GET) Dispatching request to ‘

2022-06-08T11:55:11.496-07:00 (REST) (Attempt 1) (GET) (200) Received response from ‘
2022-06-08T11:55:11.497-07:00 (Couchbase) Creating memcached connection to cluster ‘couchbase://’
2022-06-08T11:55:11.648-07:00 (Couchbase) Successfully created memcached connection to cluster ‘couchbase://’

Here’s the documentation on using host formats – https://docs.couchbase.com/server/current/tools/cbimport-json.html#host-formats
(Since you are using an ip address with the “couchbase://” prefix, it should default to using port 8091 for bootstrapping, but maybe that’s not happening. There were bugs with earlier versions with use of “couchbase://” and DNS SRV records, but it doesn’t look like you’re using a DNS SRV record. Anyways, using the http://:8091 should work if you’re running into any issues with “couchbase://”.)

Here’s the documentation on Couchbase server ports –


Thank you, the problem was in the closed port 11210.