Cbbackupwrapper/cbrestorewrapper complete successfully but no data

Hello all,

I am trying to backup/copy a bucket using Couchbase Version: 4.0.0-4051 on Mac OSX. I am using the following commands:

cd /Applications/Couchbase\ Server.app/Contents/Resources/couchbase-core/bin
./cbbackupwrapper http://localhost:8091 ./mybackup -b mydb -u Administrator -p password
./cbrestorewrapper ./mybackup http://localhost:8091 -b mydb -B mydbcopy -u Administrator -p password

These function appear to work correctly. Both backup and restore take a few seconds then return the message “SUCCESSFULLY COMPLETED!”.
“mydb” contains 891 docs. However, after restore, “mydbcopy” still shows 0 docs.

Looking at ./mybackup/logs, both files look like the commands worked as they should, so I don’t know why it’s not creating any documents. I can attach the logs if required.

Can anyone shed any light on this or what I can do to get backup and restore to work?

Also, if I specify a couple of older buckets (that I know exist because I can see them in the Couchbase web GUI), I get an error saying “the requested bucket does not exist”, which is also very strange.

It looks like it’s using a different instance of couchbase or something. However, I only have one running and I know it’s using that one because I changed the Administrator password, and the new password was required on both the web GUI and in the commands.


I have just installed CB 4.1.0 and tried again. It now works perfectly.

I’m not sure if it was the new version that fixed it or, more likely, the process of reinstalling it. I suspect that something had got messed up in my installation, although I’ve no idea what.