Cbbackup thinks a bucket does not exist

I’m running into an issue with using cbbackup on Couchbase Community Edition v4.5.1 where the tool does not think that one of our buckets exists. When performing a full backup the bucket is not processed and if trying to backup the bucket directly I am hit with error: there is no bucket: <bucket> at source: http://<HOST>. I have tried everything I can think of to sort this out and I’m at a loss. Can anyone provide some additional troubleshooting steps I could take or maybe provide some clarity as to what might be going on? Thanks!

Hi @matthew_morrissey,

Could you please provide some more details:

What is the full cbbackup command you are using?
What is the name of the bucket?
Is there a password on the bucket?
Is it a Couchbase bucket or memcached bucket?

Sure can @matthew.groves! The full command is as follows:
time /opt/couchbase/bin/cbbackup http://<hostname> /home/mmorri929/backup-test -m full -u <user> -p <password>

The name of the bucket is ‘restore_test_subscriptions’ so I also tried the following command:
time /opt/couchbase/bin/cbbackup http://<host> /home/mmorri929/backup-test -b restore_test_subscriptions -u <user> -p <password>
With that command I got the following: error: there is no bucket: restore_test_subscriptions at source: http://<host>, however the bucket definitely exists as you can see and interact with it via the UI and CLI.

I have tried this both with and without a password on the bucket and it is a Couchbase bucket.


I just tried it, and it seemed to work okay.

I’m running it on localhost. Are you running against a remote cluster? Could there be a network issue? Maybe not all the ports have been opened?

@matthew.groves I was running it on a remote where all the ports were configured appropriately. It backed up all the other buckets in the cluster fine, just not that one specifically. We’re going to do more testing and poking around to see what the deal is including re-creating the bucket. My assumption right now is that somehow that bucket was created in a manner inconsistent from the rest.


Thanks, please let me know if you find anything that sets this bucket apart. It could definitely be a bug in cbbackup, but I don’t have enough information to repro and create a ticket yet.

@matthew.groves sure thing. I’ll let you know if we find anything.