Cannot communicate with indexer process after upgrading from 4.1 to 4.5.1

I’ve just upgraded my test couchbase from 4.1.0 to 4.5.1. There is one node with little data. After upgrade the node works in general. However, when I checked logs, I can see the following error that appears every few seconds:
> Service ‘indexer’ exited with status 1. Restarting. Messages: runtime.goexit()
> /home/couchbase/.cbdepscache/exploded/x86_64/go-1.6/go/src/runtime/asm_amd64.s:1998 +0x1 fp=0xc8232e9fb0 sp=0xc8232e9fa8
> created by net/http.(*Transport).dialConn
> /home/couchbase/.cbdepscache/exploded/x86_64/go-1.6/go/src/net/http/transport.go:854 +0x10cb
> [goport] 2017/08/02 20:58:19 /opt/couchbase/bin/indexer terminated: signal: aborted (core dumped)

And this is my indexer.log: (29.5 KB)

I havent used GSIs before. I’ve tried to build one once, but then dropped this idea.

I can see in the indexer.log file, that the port 9100 is taken. It is asigned to GitLab’s process. Can I change indexer’s port? When i try do run the indexer command I get the following error;
[Error] GetSettingsConfig() failed: Get /_metakv/indexing/settings/config: Unable to initialize cbauth’s revrpc: cbauth environment variable CBAUTH_REVRPC_URL is not set

@jakub.m, you’ll have to free up port 9100 for indexer to work. This port cannot be changed.

Here’s the complete list of ports required by Couchbase for your reference:

Indexer started to work automatically after I released port 9100.

Thnaks @deepkaran.salooja