Cannot add sample bucket on MacOS Big Sur

Hello Everyone! I receive the following message when I try to add sample bucket:
“System services have not completed startup. Please try again shortly.”

Previously I installed the version 7 (beta), there it worked, but I couldn’t make the index service running, so I couldn’t add an index. I thought it might be a problem due to being a beta version, so I uninstalled it (with rm-rf all 3 directories in the documentation), then downloaded the current stable version. Now I cannot even add a sample bucket.

Do you have any idea how to fix/figure out what the problem is?

Thank you,

Hi Misi,
This error occurs when the sample bucket creation attempt occurs before the couchbase server is ready. Did the sample bucket get created/loaded when you retried?

Hi Steve,

Unfortunately not. Something went wrong with my installation after macos update and it didn’t recover. I tried to reinstall 5-6 times (added some reboots after uninstall, downloaded again, etc.), but couldn’t get the indexer service running. (I think this stopped me from adding the sample bucket ). I made a workaround and just used the dockerized version, that works great.


I am seeing the same problem here. It persists after a clean reinstall.

However I can successfully install the sample using the cmdline tool:

$ /Applications/Couchbase\ -c localhost:8091 \
      -u Administrator -p password -b testBucket -m 256 \
WARNING: cbdocloader is deprecated
JSON `file://` imported to `http://localhost:8091` successfully
Documents imported: 63288 Documents failed: 0

So the problem seems to be specific to the admin console.

Update: my installation had a problem with the indexer service.

The indexer listens on ports 9100, 9101 and 9102. Some unrelated previously installed software on my machine was listening on 9100, causing the indexer to fail.

After removing the conflict and reinstalling, the sample bucket load from the console works.