Backup an restore with cbbackup and cbrestore

Last week I’ve tried to backup my data in a single bucket
I did this command in database machine as a master of clusters, here is 4 machine which they are clusterd toghether:

cbbacup -u boo -p far -b default couchbase:// /home/test-backup

At that time the percentage of resident was 64%
after I did upper command, before it reaches to 100%
In 63% showed up backup is done and stoped without any error and warning.

Then for restoring i did this command

cbrestore -u foo -p bar test-backup/ --bucket-source default --bucket-destination default

after it’s done, there was difference in the number of documents which about to one million in 64 million document.
Before all of this senario,

  • I’ve tried with cbexport and its not good for our structure

What can I do to have real backup?

cbbackupmgr is the backup/restore utility to use with Couchbase. (cbbackup and cbrestore have been deprecated from the Enterprise Edition for a long time.) cbbackupmgr should also be available for 7.0 CE.