1.1.0 Gateway Install error on Ubuntu


I tried installing the new Gateway on Ubuntu and it failed. See below…

First I grabbed the file:

$ curl http://www.couchbase.com/dl/releases/couchbase-sync-gateway/1.1.0/couchbase-sync-gateway-community_1.1.0-28_x86_64.deb > couchbase-sync-gateway-community_1.1.0-28_x86_64.deb
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 27251 0 27251 0 0 19896 0 --:–:-- 0:00:01 --:–:-- 19891

No problems there, but then I tried to install it:

$ sudo dpkg -i couchbase-sync-gateway-community_1.1.0-28_x86_64.deb
dpkg-deb: error: `couchbase-sync-gateway-community_1.1.0-28_x86_64.deb’ is not a debian format archive
dpkg: error processing archive couchbase-sync-gateway-community_1.1.0-28_x86_64.deb (–install):
subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:

I was able to install Gateway 1.0.4 just fine on this machine…

Kind regards,

Did you try a cat on the output of what you downloaded? I think you might be surprised to find an HTML page inside. You downloaded the download landing page. The actual binary file is at this address


ahh… yeah… I’m a newb at Linux {facepalm}