XDCR on Openstack

I’m configuring CB Server 2.2.0 XDCR between two different Openstack installations. I’ve done some reading on using a DNS FQDN trick in the couchbase-server file to add a -name ns_1@(hostname) value in the start() function. I’ve tried that with absolutely zero success. There’s already a flag in the start() function that says -name ‘babysitter_of_ns_1@’ so I don’t know if I need to replace that line, comment it out, or keep it. I’ve tried all 3 of those; none of them seemed to have any positive effect.

The FQDNs are pointing to the Openstack floating_ip addresses (in amazon-speak, the “public” ones). Should they be pointed to the fixed_ip addresses (amazon: private/local) for the nodes?

When I create a remote cluster reference using the floating_ip address to a node in the other cluster, of course it’ll create the cluster reference just fine. But when I create a Replication using that reference, I always get one of two distinct errors: Save request failed because of timeout or Failed to grab remote bucket ‘bucket’ from any of known nodes.

What I think is happening is that the floating_ip isn’t being recognized or translated to its fixed_ip address prior to surfing the cluster nodes for the bucket. I know the -name ns_1@(hostname) modification is supposed to fix this, but I wonder if anyone has had success configuring XDCR between Openstack installations.