Why client configuration settings is overridden? The connection to '' failed. Error: TimedOut


I have a strange configuration of a network. I try to explain:

A. Couchbase Server - local network - vpn network. A is a single cluster node server and it’s name is ;
B. Other application Server - local network, B can’t stay on VPN.

When i try to connect from B to A with my .net sdk to do some n1ql query

  config = new ClientConfiguration
    Servers = new List<Uri> {
        new Uri(string.Format("http://{0}:{1}",
                _host, //
    BucketConfigs = new Dictionary<string, BucketConfiguration> {
        _bucket, new BucketConfiguration {
          PoolConfiguration = new PoolConfiguration {
          BucketName = _bucket

  cluster = new Cluster(config);
  bucket = cluster.OpenBucket(_bucket);
  var request = new Couchbase.N1QL.QueryRequest().Statement(qry)
  var result = bucket.Query<dynamic>(request);

I get this error:

The connection to ‘’ failed. Error: TimedOut (0x274c). System.Net.Sockets.SocketException

How can i use the same ip(local ip) that i have passed on my servers configuration?
Is there some method to override this parameter auto setted in some bootstrap moment?


When you setup a server, the wizard ask for an ip address and suggest to you but for some reason, at the end of configuration, on the cluster group it get the vpn address.

I think that this happens because the eth0 address is and the vpn address is and couchbase interprets this address how external ip. I think that this is a strange behaviour.

The only way to change this parameter, if you have only one node is to reinstall everything and explicit declare an ip address at setup.